En algunos casos de uso de la aplicación móvil para el empleado o el administrador, puede llegar a presentar algún problema al momento de querer checar, entre los cuales a continuación se mencionan algunos de los errores más comunes al momento de utilizar la aplicación móvil y el posible motivo de estos.
Solución de Errores en la Aplicación Móvil
A continuación, se mencionan algunas de los mensajes más comunes que pudiera presentar en la aplicación móvil y la posible causa y solución de esta.
1. Inavalid Credentials (Credenciales invalidas)

posibles causas
- El código de la compañía que se está colocando no existe (ID de cliente).
- El nombre de usuario es incorrecto
- La contraseña es incorrecta
- La configuración en Server Setings es incorrecta.
Solución:
por favor verifique la información ingresada en Server Settings sean correctos: en minúsculas y sin espacios en blanco
IP Hosted Address: https://mobile.kis-ta.net

Nota: no dejar espacios en blanco y todo en minúsculas
2. Punch GeoLocation not allowed (Geolocalización de checado no permitido)

posible casusas
- Este error ocurre cuando el usuario está intentando checar fuera del Área de la geolocalización permitida o asignada.
- También puede que el usuario no tiene asignado la geolocalización en la que se encuentra
Solución:
El usuario debe moverse para estar dentro del área de la geolocalización valida asignada.
Nota: si el usuario se encuentra dentro de la ubicación permitida, debe verificar en el sistema que el empleado cuenta con la geolocalización correcta asignado o el radio de la ubicación sea muy pequeño, ya que los dispositivos pueden tener cierto grado de error de precisión de la ubicación y debe ampliarlo.

3. Unable to determine location. Possible permission issue. You can´t clock in oro ut (No se pudo determinar la ubicación. Posible problema de permiso. No puedes checar tu entrada o salida)

posibles causas
- Esta advertencia ocurre cuando el usuario está intentando checar con los servicios de Geolocalización (GPS) desactivados o los acaba de habilitar para checar, pero el sistema aún no determina su localización.
- El GPS del teléfono no es capaz de determinar su ubicación, esto podría deberse a que no cuenta con señal suficiente en el dispositivo
Solución:
El usuario debe activar la geolocalización (gps) en los ajustes de su teléfono móvil, esperar unos segundos y volver a reiniciar la aplicación móvil para que reconozca el cambio.
Una forma de comprobar que el GPS nos está obteniendo una posición en el mapa, es abrir la aplicación Google maps
4. Network Error (Error de Red)


posibles causas
- Este error suele ocurrir cuando se intenta checar entrada o Salida y no se cuenta con conexión a internet por Wifi o con datos libres en el plan telefonico en ese momento para realizar el registro o la señal de conexión no es muy buena.
- El usuario no se encuentra conectado a una red wifi o datos móviles habilitados, o la conexión es limitada. puede comprobar esto accediendo algún otro sitio web como YouTube o mapas
- La configuración de la aplicación en Server Setings es incorrecta.
Solución:
El usuario debe activar los datos móviles y contar con datos libres para navegar en internet, durante el uso de la aplicación. También se recomienda conectarse a una red WI-FI para una conexión más estable y reiniciar la aplicación.
5. User not found (Usuario no encontrado)

posibles causas
- El nombre del usuario no existe o no fue encontrado en el sistema
- El código de compañía es incorrecto
- El nombre de usuario tiene algún espacio en blanco al final de la palabra
Solución:
Verifique en el portal web, que el usuario que intenta acceder, cuente con un nombre de usuario y contraseña válida. El nombre de usuario sea correcto y no contenga espacios en blanco al final de la palabra.

También el usuario debe recibir un Email con el nombre de usuario y contraseña para iniciar sesión, puede copiar y pegar directamente para evitar errores de trascripción.
6. Clocking Permissions Privileges (Privilegios de permisos en el reloj contacte a su administrador)

posibles causas
- Este error ocurre cuando el usuario no cuenta con los permisos necesarios para utilizar la aplicación móvil.
Solución:
Verifique en el portal web o solicite a su administrador verificar, que el usuario cuenta con los permisos necesarios para checar desde la aplicación: Usar Celular y Reloj en Móvil

7. Invalid Device (Dispositivo Invalido)

posibles causas
- Este error sucede cuando se está intentando acceder desde otro dispositivo (smartphone / tablet) no autorizado o no registrado
- Se realizó un cambio de dispositivo (smartphone) o se desea poder ingresar desde más de un dispositivo permitido.
Solución:
Verifique en el portal web, que el usuario cuenta con los permisos necesarios para checar desde ese dispositivo, dentro de la caja de texto de celulares permitidos, puede verificar el IME del dispositivo autorizado para ingresar a la aplicación móvil.

Nota: En caso de que el usuario cambio de dispositivo o desea permitir el ingreso desde más un dispositivo, debe borrar el IME del antiguo dispositivo registrado o Registrar el nuevo IME y Guardar.
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